View Thread
Private Stock » Administrative and Housekeeping » Site Notes
 Print Thread
Trying to upgrade the Back Room site to V8...
After the trials and tribulations upgrading this main site to PHP-Fusion v8.00.21 and finally getting it to where I want it (relatively speaking), I figured it's time to do the Back Room site. Following the upgrade instructions to the letter.

And.... I get the blank "white" screen. I am so fucking flustered about PHP-Fusion. I just want to curse it up and down, trash it and just move the fuck on to another platform. But... I always come back to it wanting the clean CMS and sectionalized separation look that no other system seems to have. So I'm trying, trying HARD, to be patient.

I'm deleting the v8 install, wiping that domain clean, and restoring the v7 files. I'm going to try yet again.
I deleted the complete domain files and folders, and then uploaded the v7 files and folders I had downloaded as backup files prior to starting the upgrade. I then ran a database restore for the SQL database. I got back in and everything worked, but many admin panel options had v8 selections that, when clicked, went nowhere (because the files were deleted). Wow, messy recovery.

Okay, so I deleted all the SQL tables in the database thru PHPMyAdmin thinking I can run the database restore again and it will add and repopulate the tables. Well f***!!! When I deleted the tables, the URL to the domain now no longer has any tables to reference!!!! WTF!!!! So the site is down, dead, blank!!! Ok. This may be a blessing in disguise if it works the way I expect. Now I'm forced to do a clean install of PHP-Fusion v8.00.21 instead of an upgrade to it. So I'm doing that now. Once the install is done... well.. I SHOULD be able to run the database restore again to rebuild all the previous tables and the site should be recovered.


We'll see...
Breathing slowly and deeply... I think I have a lot to do with this not going well... thinking I know how to approach it logically when something goes wrong, and I'm way off in the approach.

So, I did a clean complete install (vs upgrade) of v8.00.21. It completed with no issues as a clean and empty install. Then when I tried to run a restore of the tables I had previously backed up, it didn't work. It wouldn't run. What the heck am I going to do with an empty v8 site.... am I going to lose all the forum and other data?? Oh hell no.

So... I again deleted all the tables in PHPMyAdmin and deleted all the folders in the domain and started from scratch again, this time installing v7.02.07 with the PHP7 fix files on top of it. That install went well and I was at an empty v7.02.07 install site. I tried to run the restore on the backup sql.gz file. Damn thing still won't restore and repopulate the tables!! Oh damn it wasn't v8 screwing up with the restore... the restore just won't run!

I don't know how the thought occurred to me, but it did. What if I go to PHPMyAdmin and do an import of the backup file directly? I mean the format is of an export from mySQL. Hmmm. I ran the import. It worked. I went to the newly re-installed v7.02.07 site and everything is there. Whew!!!!

So now, analyzing all that I've done. I at least know how to re-install the site and repopulate the database manually.

I can't stay sitting at v7.02.07. I have to go to v8. Logically then, I can try the v8 upgrade on top of current v7.02.07. If it blanks out again, I'll scratch v7 and clean install v8 like I did once before. And this time, I'll know to run the restore manually.

Ok... here goes... as the next step, be it now or tomorrow...
Well alright then. Sitting at a clean V7.02.07 with the PHP7 fix files on top of it, I went thru the upgrade to v8.00.21 again, step by step. It appears to have been successful with no extraneous needs to restore the database or re-copy over the backed up files. Methinks we're sitting pretty now... until it's time to finally commit to going to v9. But that's an other bridge to cross when it becomes necessary.
Jump to Forum